Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL Webou Webou Pro
Recherche avancée  
*
Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre courriel d'activation?
23 Novembre 2017, 23:17:30


Connexion avec identifiant, mot de passe et durée de la session


Pages: [1]   Bas de page
  Imprimer  
Auteur Fil de discussion: [FLASH] Animation non chargée !  (Lu 4695 fois)
0 Membres et 1 Invité sur ce fil de discussion.
StoneCircus
Petit padawan
Nouveau
*
Hors ligne Hors ligne

Messages: 12



Voir le profil WWW
« le: 20 Juin 2007, 23:18:38 »

Bonjour à tous,

J'ai réalisé une version anglaise de mon site. Pour que le visiteur puisse choisir la langue dans laquelle il veut voir affiché le site, j'ai créé une nouvelle index.html avec un lien d'entré différent pour chaque langue. J'ai décidé d'y inclure une petite animation Flash réalisé par mes soins...pour le fun !

Mon problème est le suivant : lorsque ma page index.html se charge, l'animation Flash n'est pas affichée ! J'ai, à la place de celle-ci, un gros carré blanc.

Voila l'adresse de mon site : stone-circus.com

Merci d'avance pour votre aide !
Journalisée

Peace n'fuck
Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL
« le: 20 Juin 2007, 23:18:38 »

 Journalisée
K@cem
Never trust user input
Big boss
*****
Hors ligne Hors ligne

Messages: 2 724



Voir le profil WWW
« Répondre #1 le: 20 Juin 2007, 23:48:55 »

Peux tu nous donner le code de ta page index ??
Journalisée

Le support ne se fait pas par MP, merci de le respecter !
StoneCircus
Petit padawan
Nouveau
*
Hors ligne Hors ligne

Messages: 12



Voir le profil WWW
« Répondre #2 le: 20 Juin 2007, 23:57:41 »

Le voici : (j'ai mis toute la page en pièce jointe)

<body>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="716" height="480">
<param name="movie" value="intro.swf">
<param name="quality" value="high">
<embed src="intro.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="716" height="480">
</embed>
</object>
<a href="Pages/indexfr.html" class="Style2"><font size="5">Entrer</font></a>
<a href="Pages/indexA.html" class="Style2"><font size="5">Enter</font></a>
</div>
</form>
</body>

Merci pour l'intérêt que tu portes à ma question et pour ta rapidité de réaction ! (Beaucoup mieux que toute les hotlines du monde...et surtout beaucoup moin cher ! )
Journalisée

Peace n'fuck
K@cem
Never trust user input
Big boss
*****
Hors ligne Hors ligne

Messages: 2 724



Voir le profil WWW
« Répondre #3 le: 21 Juin 2007, 00:34:53 »

Ton animation se trouve sur la racine de ton site ?
(C'est à dire dans le dossier public_html ...)
Journalisée

Le support ne se fait pas par MP, merci de le respecter !
StoneCircus
Petit padawan
Nouveau
*
Hors ligne Hors ligne

Messages: 12



Voir le profil WWW
« Répondre #4 le: 21 Juin 2007, 00:38:15 »

Oui, elle est bien à la racine de mon site, et elle s'appelle bien "intro.swf".
Journalisée

Peace n'fuck
Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL
« Répondre #4 le: 21 Juin 2007, 00:38:15 »

 Journalisée
K@cem
Never trust user input
Big boss
*****
Hors ligne Hors ligne

Messages: 2 724



Voir le profil WWW
« Répondre #5 le: 21 Juin 2007, 00:42:20 »

Ton code est correcte !
Je pense que c'est un problème causé par les frames ...
Donc en gros ton code, tu l'as mis dans une frame qui n'est pas à la racine du site, ou il est dans la page index.html ??
Journalisée

Le support ne se fait pas par MP, merci de le respecter !
StoneCircus
Petit padawan
Nouveau
*
Hors ligne Hors ligne

Messages: 12



Voir le profil WWW
« Répondre #6 le: 21 Juin 2007, 00:53:19 »

Je viens de trouver la solution...c'est fou !  Choqu&eacute;

Mon fichier s'appelait "INTRO.swf" et dans ma page HTML il était nommé "intro.swf". Je viens de le renommer en minuscules et...ca marche !
Je ne savais pas que le HTML prenait en compte la casse. J'ai appris quelque chose aujourd'hui ! Yihi !

Merci pour ton aide et ton attenton K@cem.

Pourrais-tu me rendre un dernier service ? Je viens de visiter ma page et mon animation à beaucoup de mal à charger. Normalement c'est juste un effet de "fade-in fade-out" (fondu noir-->image-->noir, en boucle), donc pas de raison que ça charge autant. Pourrais-tu me dire si ça charge longtemps chez toi (avant que l'animation soit fluide), ou si c'est ma connexion qui foire !?

Merci d'avance.
« Dernière édition: 21 Juin 2007, 01:25:27 par StoneCircus » Journalisée

Peace n'fuck
K@cem
Never trust user input
Big boss
*****
Hors ligne Hors ligne

Messages: 2 724



Voir le profil WWW
« Répondre #7 le: 21 Juin 2007, 01:06:21 »

Au début c'était long à charger, mais après la boucle devient un peu plus rapide ...
Je n'ai jamais fais du flash mais je pense que c'est anormal Sourire
Journalisée

Le support ne se fait pas par MP, merci de le respecter !
Clem0902
Sr. Member
****
Hors ligne Hors ligne

Messages: 488



Voir le profil WWW
« Répondre #8 le: 21 Juin 2007, 07:14:14 »

Chez moi qui a une bonne connexion le chargement du flash reste très très lent !
Journalisée

Dr House Fan : Votre source française sur la série Dr House
Merci de faire une recherche avant de poster votre problème !
StoneCircus
Petit padawan
Nouveau
*
Hors ligne Hors ligne

Messages: 12



Voir le profil WWW
« Répondre #9 le: 21 Juin 2007, 09:46:40 »

Ok ! Sourire
Je crois que je vais essayer d'optimiser mon animation et peut être créer une barre de chargement.

Encore une fois merci.

Vive le Quebec libre !  Huh
Journalisée

Peace n'fuck
K@cem
Never trust user input
Big boss
*****
Hors ligne Hors ligne

Messages: 2 724



Voir le profil WWW
« Répondre #10 le: 21 Juin 2007, 12:58:54 »

yes bonne chance Sourire
Journalisée

Le support ne se fait pas par MP, merci de le respecter !
Pages: [1]   Haut de page
  Imprimer  
 
Aller à:  

Propulsé par MySQL Propulsé par PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Dilber MC Theme by HarzeM
Page générée en 0.02 secondes avec 21 requêtes.