Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL

Programmation => PHP/MySQL - (x)HTML - ... => Discussion démarrée; par: doudou le 29 Octobre 2007, 07:14:26



Titre: Probleme d'installation
Posté par: doudou le 29 Octobre 2007, 07:14:26
Bonjour poil,

J'espere ne pas vous deranger
J'ai besoin de quelques informations svp.
Voila j'ai suivi un tuto sur phpcs et j'ai quelques problemes avec l'installation d'un espace membre.
ici==> http://www.phpcs.com/codes/CREER-ACCES-MEMBRE-SUR-VOS-PAGES-AVEC-FORMULAIRE_26795.aspx

voici les infos que j'ai eu a rentrer . il y'a t-il une erreur?

<< // DEBUT - Reglages
$db_host="localhost";   
$db_user="doudou_doudou";  //
$db_pass="******";         //
$db="doudou_doudou";       //
$site_name="www.business.webou.net ";       //
$serveur="ftp.webou.net"; //
$mail_controle=1; //
$adresse_webmaster="adrien.pascalpoly@gmail.com";//
$validite=1*24*7;         //
$page_redirection="www.business.webou/index.html";//
//
mysql_connect($db_host,$db_user,$db_pass) or die("Unable to connect to database");
mysql_select_db($db) or die("Unable to select database");
?>                       >>

Voici mon user name sur webou: doudou et le mot de passe est ******
voici aussi l'adresse ou je dois faire les reglages: http://business.webou.net/security/

Je vous remercie d'avance pour votre aide.


Titre: Re: Probleme d'installation
Posté par: Poil le 29 Octobre 2007, 08:38:59
Supprime ton user et mdp................


Titre: Re: Probleme d'installation
Posté par: MIkE le 29 Octobre 2007, 16:04:33
Si tu ne veux pas de problème, évite de mettre ton mdp sur le forum évidemment, puisque le forum est visible par tout le monde...

Pour db, db user et password, il faut que tu créées la bdd et le user mysql dans le panel (www.webou.net:2082).


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 30 Octobre 2007, 11:33:53
bonjour,

je suis moi même totalement perdu, j'ai bel et bien mon hébergement, j'ai réussis avec file zilla a exporter les données sur mon serveur, je parle ici d'Ogspy, mais quand il me dit de trouver l'url où j'ai mis mes fichiers pour lancer la procédure d'installation je ne sais absolument pas où aller...

de plus, quand je suis sur le panneau d'administration de mon serveur, visiblement le php et autres fonction ne sont pas activées par défaut, j'ai pourtant cliqué sur "phpMyadmin" dans le panneau de controle pour changer ça, cela m'envoie sur une page où je comprend encore moin ce que je dois faire...

vous l'avez compris je suis une quiche en informatique xD et je souhaiterai simplement pouvoir installer un serveur ogspy mais je suis perdu

merci d'avance pour votre aide

mon nom de domaine que j'ai reçu par mail aprés la demande d'hébergement faites ici est :

asgards-univers54.webou.net

voila...


Titre: Re: Probleme d'installation
Posté par: Poil le 31 Octobre 2007, 20:44:34
Quel est l'extention de ton fichier?


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 31 Octobre 2007, 20:47:48
l'exention de mon fichier ? euhhh je vois pas de quoi tu parle


Titre: Re: Probleme d'installation
Posté par: Poil le 31 Octobre 2007, 21:43:30
Extension désoler faute de ma part...


Titre: Re: Probleme d'installation
Posté par: K@cem le 31 Octobre 2007, 23:21:27
Je n'ai pas compris ton premier message ...
Tu as transféré tes fichiers dans ton espace web, mais après ?

(Attention : il faut mettre tes fichiers dans le dossier public_html !)


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 00:10:42
problème c que je crois que j'avais supprimé tous les dossiers de mon hébergeur...pour en faire un seul avec les fichiers transféré via file zilla , alors je sais plus quoi faire pour lancer la procédure d'installation et la configuration du PHP


Titre: Re: Probleme d'installation
Posté par: Poil le 01 Novembre 2007, 10:29:27
Tu supprime le fichier installe et tu en remet celui d'origine. Et si sa ne marche pas il faut supprime les fichier qui vont avec et les remettre.


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 11:53:46
ça marche toujours pas.....*roi des boulets* snif


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 11:59:19
http://asgards-univers54.webou.net donne une erreur 404.

C'est parce que tu as supprimé le dossier public_html. Il faut le recréer et transférer tous les fichiers de ton site dans ce dossier.


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 12:10:24
beh acces denied quand je veux remettre le dossier public_html, a moins que ça soit directement sur le serveur que jdois faire ça ?


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 12:32:23
Oui, c'est bien sur le serveur.

Pour faire simple, il faut que tu te connectes au serveur avec filezilla -> à la racine (la base) tu crées le dossier public_html .


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 13:51:39
j'ai finalement réussis à lancer la procédure d'installation d'ogspy et il m'a mis en message installation compléte effectuée ! puis il m'a dit supprimer le dossier install je l'ai fait, et c'est maintenant là que ça bug, voici le message :

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@asgards-univers54.webou.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.37 Server at asgards-univers54.webou.net Port 80


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 14:22:53
Tu peux voir la cause de l'erreur dans le panel, dans "registre d'erreur".

A 99% tu as fait un ou plusieurs CHMOD 777 sur tes fichiers, alors que ce n'est pas nécessaire sur webou (et c'est même dangereux pour la sécurité, d'où l'erreur).

Remets les permissions normales 644 ou 755.


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 15:17:23
ah ok euh...il ya pas une commande pour remettre les permissions par défaut ?  ::) ???


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 15:43:56
Je ne pense pas non, mais ça peut se faire rapidement (mais il faut le faire dossier par dossier).


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 16:09:34
j'ai fait...mais il me dit à présent une fois l'installation terminée, impossible de se connecter à la base de donnée

quesque jdois faire ? :( rah jsuis sur le point de laisser tomber tellement j'en peux plus...


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 16:19:38
As tu bien créé la BDD, l'utilisateur qui va avec et lié la BDD à l'utilisateur?


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 17:15:50
dis moi...est ce que je pourrai pas t'envoyer toutes les info de connexion à mon hébergement pour que tu vérifie ce qui cloche afin que je puisse enfin disposer d'un serveur ogspy ? :( si ça te dérange pas répond moi et je t'enverrai les informations
 
car là je suis largué je sais plus quoi faire
 
merci d'avance...


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 17:47:26
C'est pas vraiment possible, je ne peux pas aider chaque personne qui est hébergée ici en faisant l'installation à sa place.

Tu peux demander à un ami de t'aider, ou le faire toi même c'est mieux en continuant à nous dire où tu bloques.


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 17:53:02
ok jcomprend, bah oui la BDD est créée, donc je sais pas où ça coince et pourquoi ça me met : Impossible de se connecter à la base de données  , comment faut il encore configurer la BDD pour que cela fonctionne ? :s merci pour le temps que vous me consacrez


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 18:09:44
As tu bien créé la BDD, l'utilisateur qui va avec et lié la BDD à l'utilisateur?
Ensuite, il y a un fichier à modifier (id.php ?) avec ces données.


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 18:56:31
oui j'ai créé ça, par conte j'ai pas modifié le fichier dont tu parle ! c surmen ça ! que faut il que je modifie sur ce fichier ??


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 19:07:49
Je ne connais pas très bien ogspy, mais je sais qu'il y a un tuto pour son installation dans le forum des tutos et dans celui d'ogspy, tu l'as suivi?


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 19:12:24
bah oui >__< sinon je serai pas ici, ils m'ont dit qu'il pouvais rien faire vu que ça concerne l'hébergeur...d'où ma demande d'aide ici... :(


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 20:11:36
Donc, tu as réussi à acceder au fichier pour l'installation mais il n'arrive pas à se connecter à la BDD?


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 20:20:54
exactement....mais là je n'arrive même plus à lancer la procédure d'installation ça m'énervvvvveeeeeeuuuu


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 20:24:40
Re transfères le dossier install, on va voir ce qu'on peut faire.


Titre: Re: Probleme d'installation
Posté par: MIkE le 01 Novembre 2007, 21:31:09
Ou bien, recommence tout depuis le début, j'ai fait un tuto complet : http://www.webou.net/communaute/index.php/topic,1461.0.html


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 01 Novembre 2007, 21:48:17
ça marche enfin ! merci ! :D


Titre: Re: Probleme d'installation
Posté par: doudou le 02 Novembre 2007, 02:27:51
Si tu ne veux pas de problème, évite de mettre ton mdp sur le forum évidemment, puisque le forum est visible par tout le monde...

Pour db, db user et password, il faut que tu créées la bdd et le user mysql dans le panel (www.webou.net:2082).

c'est fait mais ca ne marche toujours pas.
désolé pour le retard


Titre: Re: Probleme d'installation
Posté par: MIkE le 02 Novembre 2007, 11:51:13
Ce tuto pourra t'aider : http://www.webou.net/communaute/index.php/topic,1186.0.html


Titre: Re: Probleme d'installation
Posté par: doudou le 03 Novembre 2007, 01:47:01
ok j'essayerai merci :-)


Titre: Re: Probleme d'installation
Posté par: -Osiris- le 03 Novembre 2007, 13:46:22
il y a régulièrement des problèmes avec l'hébergement, soit l'ip dédié n'est plus affichée dans le panel et il y a un immense message d'erreur, ou encore il n'arrive pas à se connecter à la base de donnée ou encore j'ai divers message d'erreurs, bref un jour sur deux quasiment ça bug puis ça reviens à la normal...est ce que webou connait des diffucultées d'ordre technique ces temps ci ?  ???


Titre: Re: Probleme d'installation
Posté par: K@cem le 03 Novembre 2007, 13:48:42
Il y avait des problèmes hier, mais ça ne s'est jamais produit depuis le tranfert vers le nouveau serveur !


Titre: Re: Probleme d'installation
Posté par: MIkE le 03 Novembre 2007, 16:22:36
En effet ça fait 6 mois que le serveur est on ne peut plus stable.
Depuis 2 jours il y a des problèmes, mais on est en train de les résoudre, ça va aller mieux ;)