Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL

Hébergement Webou.net => Hébergement Webou.net => Discussion démarrée; par: K@cem le 17 Février 2008, 14:31:02



Titre: Bugs sur le nouveau site
Posté par: K@cem le 17 Février 2008, 14:31:02
Bonjour,
Le nouveau site est enfin mis en ligne, à première vue il n'y a aucun bug mais je suis sûr que quelqu'un trouvera bien une anomalie quelque part :)
C'est pour cette raison que j'écris ce post, je voudrais que vous postiez ici tous ce que vous ne trouvez pas normal, que ça soit une faute d'orthographe ou une erreur php ou mysql !
Merci de faire une rédaction clair accompagné de l'url de la page où vous avez trouvé le bug, ou un screen si vous ne pouvez décrire l'erreur ;)

Ne répondez à ce sujet que si vous avez trouvé quelque chose, sinon votre post sera supprimé sans préavis !

Je compte sur vous, merci.


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 17 Février 2008, 14:42:34
Salut k@cem,

Alors tout d'abord, bravo pour le nouveau site : très classe, très clair, il est en harmonie avec le forum... Nickel !

J'ai parcouru un peu, et tout ce que j'ai trouvé pour l'instant, c'est une petite coquille sur la page http://www.webou.net/offres.hebergement-gratuit.html (http://www.webou.net/offres.hebergement-gratuit.html) : "Une accès FTP par compte".

Voilà, sinon pour l'anecdote, il y a "Vérification des modules de vérification" (dans une page du site que je n'arrive pas à retrouver, et qui liste les phases de test avant la reprise des inscriptions). Ca fait beaucoup de "vérification" dans la phrase mais en même temps ça veut dire quelque chose, donc... ;D

Encore bravo !

Thierz


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 17 Février 2008, 14:49:17
Merci, c'est corrigé ;)
La 2ème "faute" était ici : http://www.webou.net/news-2-id27.html
Ce n'est pas réellement une faute, parce qu'on a nommé un module que j'avais fais par "module de vérification", j'ai remplacé vérification par test, c'est  mieux maintenant ;)


Titre: Re: Bugs sur le nouveau site
Posté par: Kykoonn le 17 Février 2008, 16:50:59
hello :)

Bon c'est pas un bug, juste une suggestion : maintenant que le site est tout beau, pourquoi ne pas faire un bouton de retour au site sur le forum ?
Ajouter un truc genre :

Code:
                                <td align="center" class="menubg2">
<a href="http://www.webou.net">Site</a>
</td>

au début de ton menu, ce qui donnerait au final un :

Code:
<tr>
<td align="center" class="menubg" height="30" width="20">

</td>


<td align="center" class="menubg2">
<a href="http://www.webou.net">Site</a>
</td>
<td align="center" class="menubg2">
<a href="http://www.webou.net/communaute/index.php">Accueil</a>
</td>
<td align="center" class="menubg">
<a href="http://www.webou.net/communaute/index.php?action=help">Aide</a>
</td>
<td align="center" class="menubg">

<a href="http://www.webou.net/communaute/index.php?action=search">Rechercher</a>
</td>
<td align="center" class="menubg">
<a href="http://www.webou.net/communaute/index.php?action=profile">Profil</a>
</td>
<td align="center" class="menubg">
<a href="http://www.webou.net/communaute/index.php?action=pm">Mes Messages Priv&eacute;s </a>
</td>

<td align="center" class="menubg">
<a href="http://www.webou.net/communaute/index.php?action=mlist">Membres</a>
</td>
<td align="center" class="menubg">
<a href="http://www.webou.net/communaute/index.php?action=logout;sesc=2097417d7b030982d82e5c1fef7827f7">D&eacute;connexion</a>
</td>
<td align="center" class="menubg" width="20">
</td>

</tr>

Bon après ce n'est qu'une suggestion hein ;)

Sinon, très joli site, et super taff, bravo !! ;)

Kykoonn
            


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 17 Février 2008, 18:49:11
Yo k@cem, encore une petite fournée de remarques, page http://www.webou.net/faq.html (http://www.webou.net/faq.html)... Ca sent la fatigue et le codage à 2h du matin, tout ça ;)

Comment demander un hébergement gratuit? (espace avant le ?)
Comment récupérer mon mot de passe perdu? (idem)
(...) sinon vous ne pourrez accéder à la page demandé ;) --> demandée
(...) votre demande sera alors étudié par les Administrateurs --> étudiée
Plusieurs languages et thèmes sont disponibles pour une meilleure naviguation ^^
(...) cliquez sur annuler comme le montrent les images ci dessous

Thierz - je continue à chercher ;D


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 17 Février 2008, 20:58:30
@Kykoonn : C'est prévu ;)

@Thierz : C'est vrai que j'ai rédigé la FAQ un peu trop vite (c'est presque la dernière chose que j'ai fait ...)
Je vais corriger cela, merci


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 17 Février 2008, 21:04:40
Merci à tous pour les remarques :)


Titre: Re: Bugs sur le nouveau site
Posté par: mariepizza le 17 Février 2008, 22:44:14
Kacem, à première vue s'écrit avec un e. J ;D
 


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 17 Février 2008, 22:54:09
Kacem, à première vue s'écrit avec un e. J ;D
 
:P


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 17 Février 2008, 23:04:23
Une dernière salve de coquilles avant d'aller me pieuter... Au fait, j'avais pas fait gaffe lors de mon premier passage, mais très beau boulot pour la compatibilité XHTML 1.0 Strict !!! Ca fait plaisir de voir que certains sites se préoccupent de respecter les standards !

Page d'accueil :
Avec le panel d'administration disponible, vous pourrez tout configurer et contrôler : vos bases de données (...) (voire même : "votre base de données" vu qu'il y en a 1 par compte)
Pour chaque clic sur ces bannières, webou touche une petite somme (...) (manque aussi une majuscule sur Webou) ;)
Les logos sont disponibles ici, sur la page des ressources <-- terminer la phrase par un point

Voilà, je crois que j'ai fait un tour assez complet. Pas de lien mort, toutes les pages certifiées XHTML 1.0 Strict... Que du bonheur :)


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 17 Février 2008, 23:30:55
En effet k@cem a fait un très très bon boulot.

Malheureusement, je dois un petit peu casser cette belle validation avec les publicités gérées par comclick  (20 erreurs par page :-\). J'étudierai d'autres possibilités pour ne pas devoir gâcher la validation, mais pour l'instant les rentrées d'argent sont prioritaires ;).

J'ai corrigé les autres erreurs, merci :)


Titre: Re: Bugs sur le nouveau site
Posté par: Arthur70 le 18 Février 2008, 09:57:44
Bien joli travail que ce nouveau site...

A mon tour de me montrer "pinailleur".

Page d'accueil - Menu gauche

Pas vraiment une erreur mais un verbe conjugué et pas l'autre ?
Demander un hébergement
Testez votre bande passante

Page d'accueil - Menu haut

Profile

Dans le texte

C'est la paire qui conviendra le mieux
combinaison serait peut être un meilleur terme

Dans Infos du profil - Sommaire
Accent disgracieux sur Age

Dans Infos du profil - voir les statistiques
Temps total pass?eacute; en ligne:


Bonne continuation à vous et merci pour l'outil.


Titre: Re: Bugs sur le nouveau site
Posté par: Arkhena le 18 Février 2008, 12:50:31
Salut!

Vraiment sympa cette nouvelle charte graphique, j'adoooooooooooore!  ;)

Merci les gars  :D

Arkhena


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 18 Février 2008, 14:04:52
Salut,
J'ai mis couple au lieu de paire, c'est mieux ?


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 18 Février 2008, 14:15:52
Couple c'est bien oui, mais j'aimais bien paire aussi, soit :)

Les deux derniers "bugs" sont dûs à SMF ;)


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 18 Février 2008, 14:18:54
Les deux derniers "bugs" sont dûs à SMF ;)

Je suis entrain de chercher le fichier où il y a la trad en Français  :P

Edit : Corrigé ;)


Titre: Re: Bugs sur le nouveau site
Posté par: wiirox le 18 Février 2008, 21:49:00
J'aime bien, il est simple ::)

C'est sympa, et cliquez tous sur les annonces googles :P
Comme ça Webou sera riche, et on aura plein de serveurs  ;D


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 20 Février 2008, 13:33:30
Hé hé hé... Une dernière fournée de coquilles, sur la page... de réception des demandes d'inscription  ;D ;D ;D

Votre demande a été enregistrée avec succès <-- terminer la phrase par un point

Vous recevrez un email (sur l'adresse que vous avez indiquée lors de l'inscription au forum) vous indiquant si votre site est accepté ou non dans les plus brefs délais ...


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 20 Février 2008, 13:50:21
Autre petit bug lors de la soumission d'une demande d'hébergement :

J'ai essayé avec une majuscule sur mon pseudo : c'est refusé (jusque là c'est normal).

Mais suite au refus, je reviens sur la page de demande : ma demande est criblée de caractères / ou \ (je ne sais plus lequel). Si je rééchoue, la demande se remplit de // ou \\, et ainsi de suite : /// ou \\\, //// ou \\\\ (surement un caractère d'échappement pour les apostrophes).

Je ne sais pas si je suis très clair... :o


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 20 Février 2008, 15:24:05
Corrigé (à part les \ pour lesquels k@cem devra regarder :) )


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 20 Février 2008, 21:30:22
Il faut désactiver les magic_quotes !
J'ai essayé la méthode htaccess et php.ini, mais sans succès ...
Pourquoi ne pas la mettre OFF par défaut ?


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 20 Février 2008, 22:29:51
Attention aux possibles régressions sur les sites hébergés par Webou ! Il m'est arrivé cette mésaventure chez un autre hébergeur, les magic quotes ont changé sans préavis, ce fut un beau... bazar ;D pour rester poli...


Titre: Re: Bugs sur le nouveau site
Posté par: Arkhena le 20 Février 2008, 22:52:46
Il faut désactiver les magic_quotes !
J'ai essayé la méthode htaccess et php.ini, mais sans succès ...
Pourquoi ne pas la mettre OFF par défaut ?

ça ne sert pas à empêcher les failles de sécurité de type injection SQL?


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 21 Février 2008, 12:45:49
ce n'est pas à php de sécuriser les variables mais c'est le développeur qui doit le faire !
D'ailleurs les magic_quotes seront supprimé avec php6 ;)


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 21 Février 2008, 14:20:00
A priori même si il php est compilé avec magic quotes il n'est pas activé par défaut : http://www.webou.net/phpinfo.php


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 21 Février 2008, 23:08:32
C'est réglé ;)


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 21 Février 2008, 23:31:00
La classe 8)

Allez, une dernière remarque : dans le mail qui confirme que ma demande d'hébergement a été acceptée, j'ai eu un soucis (qui n'en était peut-être pas un). En consultant le mail sur l'interface web de laposte.net, tous les accents étaient remplacés par un caractère bizarre (un petit losange noir avec un "?" au milieu). Par contre une fois téléchargé par pop3 et ouvert dans Outlook Express, tout était nickel...

Voilà, c'est juste du peaufinage... En tout cas encore bravo !


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 21 Février 2008, 23:37:55
Je pense que c'est la faute de laposte qui sécurise les messages avec la mauvaise fonction ;)
Si quelqu'un d'autre signale ce problème j'essayerai une solution !


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 21 Février 2008, 23:51:18
Je viens d'apercevoir le même symbole losange + "?" dans le forum, quand une personne est connectée et que la souris survole la petite icône pour lui envoyer un message : le tooltip affiche un truc genre : "Message personne[?] (en ligne)"

J'utilise Firefox.


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 21 Février 2008, 23:58:24
La traduction du forum est mal faite, je l'ai corrigé merci MONSIEUR Thierz ;D


Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 22 Février 2008, 12:13:04
MDR ;D


Titre: Re: Bugs sur le nouveau site
Posté par: crbelouizdad le 23 Février 2008, 00:00:55
trop fort la charte

merci beaucoup l'équipe pour tous le travail que vous faite ;)

bonne continuation


Titre: Re: Bugs sur le nouveau site
Posté par: momal le 24 Février 2008, 22:11:42
bonsoir ,

Sur le forum une fois connecter, pour les gens n'ayant pas de compte ....

 > Messages non lus depuis votre dernière visite.
> Réponses à vos messages.
> Vous n'avez pas de compte, vous pouvez en faire une en cliquant sur ce lien.
Si vous avez déjà un ancien compte veuillez le lier à notre base de données en cliquant ici.
 
 @ +


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 25 Février 2008, 16:26:15
J'ai enlevé tous le message, il ne sert plus à rien maintenant ;)


Titre: Re: Bugs sur le nouveau site
Posté par: chardetm le 27 Février 2008, 13:16:11
Dans MES MESSAGES PRIVES quand on a pas de message :

Pas de messages...

Pas de -s s'il n'y en a aucun !

EDIT : k@cem regarde ta signature : Le support nese fait pas par MP, merci de le respecter !


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 27 Février 2008, 18:28:49
Salut,
Pour le "s", c'est trop de bouleau pour peu de chose !
Sinon pour ma signature, je l'aime bien comme ça :)


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 28 Février 2008, 09:22:39
Et le "s" pour la quantité 0 n'est pas vraiment une faute ;)


Titre: Re: Bugs sur le nouveau site
Posté par: chardetm le 28 Février 2008, 23:21:17
Pour le "s", c'est trop de bouleau pour peu de chose !

Lol ! En tout cas, j'espère que les inscriptions pour l'hébergement seront à nouveau disponibles rapidement !


Titre: Re: Bugs sur le nouveau site
Posté par: Arkhena le 02 Mars 2008, 13:08:52
Je ne sais pas si c'est du à mon IE 7, mais j'ai ça sur la page d'accueil :

(http://img526.imageshack.us/img526/316/weboujv0.th.jpg) (http://img526.imageshack.us/my.php?image=weboujv0.jpg)
Je ne l'ai pas sous firefox et je crois que je n'avais pas ce bug graphique il y a quelques jours.

Je peux me tromper, mais je pense qu'il faudrait modifier le css ainsi (design.css (ligne 303)):
Code:
.bloc ul {
list-style-image:none;
list-style-position:outside;
list-style-type:none;
margin-left:-40px; <-- Ligne à changer
}
Devient :

Code:
.bloc ul {
list-style-image:none;
list-style-position:outside;
list-style-type:none;
padding-left:0px; <-- Ligne changée
}


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 02 Mars 2008, 20:43:12
J'ai fais quelques modifications au niveau du CSS mais j'ai oublié de tester sous IE !
C'est maintenant corrigé, merci ;)


Titre: Re: Bugs sur le nouveau site
Posté par: Arkhena le 05 Mars 2008, 11:35:36
De rien  :D


Titre: Re: Bugs sur le nouveau site
Posté par: webgraph le 10 Mars 2008, 17:31:41
Depuis le 31 janvier, jour de mon inscription je désespère de pouvoir obtenir un hébergement : je suis devant ce mur infranchissable [ Les demandes sont suspendues pendant les tests du nouveau site et reprendront cette semaine.

Restez attentifs entre-temps ;) ]

Pouvez-vous donner des explications à cette citation lapidaire et au combien frustrante ?

Merci pour l'hébergement gratuit, on en a pour son argent...




Titre: Re: Bugs sur le nouveau site
Posté par: Thierz le 11 Mars 2008, 00:11:44
Pouvez-vous donner des explications à cette citation lapidaire et au combien frustrante ?
Salut,

Cela fait 2 jours que k@cem ne se connecte pas, 3 jours pour MIkE, donc si je devais me hasarder à un pronostic, je dirais qu'ils sont très occupés. Ce sont des choses qui arrivent, surtout qu'ils bossent bénévolement pour Webou (ça veut dire qu'ils ont un boulot à côté probablement). Comme je suis quelqu'un d'assez optimiste, j'ai envie de croire que tout rentrera bientôt dans l'ordre, et que tu pourras t'inscrire bientôt, mais bon d'un autre côté je ne connais pas tous les problèmes liés au nouveau site, si ça se trouve y'en a encore plein qu'on ne voit pas forcément...

Allez courage !


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 12 Mars 2008, 20:38:28
Salut,
Perso je suis très occupé en ce moment, je pense que Mike l'est aussi :)
On ouvrira les demandes dès qu'on sera un peu plus libre, parce qu'il est inutile de les ouvrir sans les traiter (ce qui va augmenter le temps de réponse ! ) ;)
Merci de votre patience :)


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 14 Mars 2008, 00:24:25
Hello,

En effet, j'ai pris beaucoup de retard partout désolé, mais je vous rassure, je suis là.

Et avec le recrutement des modérateurs qui va être finalisé, k@cem et moi serons moins seuls et ça avancera plus vite.


Titre: Re: Bugs sur le nouveau site
Posté par: samuelvergnaud le 01 Mai 2008, 22:55:03
sur la page de contact, j'essayais de supprimer mon compte webou, mais impossible d'envoyer le formulaire avec le captcha qui ne fonctionne pas


Titre: Re: Bugs sur le nouveau site
Posté par: MIkE le 02 Mai 2008, 10:02:05
Bonjour,

Pas de problème de captcha ici. Essayé avec IE et Firefox?


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 02 Mai 2008, 15:31:16
Chez moi aussi ça marche pas, pourtant c'est le même code que sur la version dev du site qui marche bien ...
Le problème n'est pas au niveau du captcha mais de la session, je vous informerai lorsque le bug sera corrigé ;)
++


Titre: Re: Bugs sur le nouveau site
Posté par: K@cem le 07 Mai 2008, 21:52:36
sur la page de contact, j'essayais de supprimer mon compte webou, mais impossible d'envoyer le formulaire avec le captcha qui ne fonctionne pas
Réglé ;)