Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL

Programmation => PHP/MySQL - (x)HTML - ... => Discussion démarrée; par: jpdollo le 27 Juillet 2008, 11:05:10



Titre: Affichage des lettres accentuées dans une page .php
Posté par: jpdollo le 27 Juillet 2008, 11:05:10
Bonjour

J'ai bien réussi à faire un include dans mon fichier .php

Toutefois j'ai un problème :
                   Les lettres accentuées ne s'affichent pas normalement

Quelqu'un peut-il m'aider

Merci d'avance

Jean Paul


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: K@cem le 27 Juillet 2008, 11:29:05
Salut,
C'est quoi l'encodage de ton fichier (ISO, UTF ...) ?
Donne nous le header de ta page html
++


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: jpdollo le 27 Juillet 2008, 12:22:11
Voila

<?php  /* Du code php */ ?>
<!DOCTYPE html
     PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-Transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head>
<title>Les Trains Touristiques du Monde</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta name="description" content="Tous les trains,  vapeur, électriques, les tramways, les cremailleres touristiques du monde entier, Europe, Amerique, Afrique, Australie, Asie, Voyages d'une heure, un jour, une semaine"/>
<meta name="keywords" content="tourisme, touristique, decouverte,trains,train,vapeur,train à vapeur, prestige,trains de prestige,electrique, train electrique,tramway, autorail,cremaillere, train a cremaillere"/>
<meta name="robots" content="all"/>
<meta name="revisit-after" content="2 days"/>
<meta http-equiv="Content-language" content="fr-FX"/>
<meta name="author" content="Jean Paul DOLLO"/>
<meta http-equiv="Reply-to" content="jp.dollo@gmail.com"/>
<link rev="made" href="mailto:jp.dollo@gmail.com"/>
<meta name="copyright" content="Jean Paul DOLLO"/>
<meta name="verify-v1" content="String_we_ask_for"/>
<link rel="stylesheet" type="text/css" media="screen" href="CSS.css"/>
<meta name="verify-v1" content="zG0wqY6JXxShtr4OjH4fO/fGpWMDzcggDQquF0ZALPE=" />
</head>

<div class="Pied">
<?php include "Pied.php";?>
</div>

<body>

</body>
</html>

et dans page d'origine

<?php  /* Du code php */ ?>
<!DOCTYPE html
     PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-Transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head>
<title>Document sans titre</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>


Merci


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: K@cem le 27 Juillet 2008, 15:04:45
Ton fichier est encodé en quel format ?


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: jpdollo le 27 Juillet 2008, 15:09:07
Ai tout montre


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: nitro007 le 27 Juillet 2008, 15:21:08
Met le tout en iso-8859-1  ;) jai déjà eu ce problème.


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: jpdollo le 27 Juillet 2008, 15:23:57
Tu as pu resoudre le probleme?


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: nitro007 le 27 Juillet 2008, 15:47:19
oui, dans le head tu met a la place <meta http-equiv="Content-Type" content="text/html; "/iso-8859-1>  :P


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: jpdollo le 27 Juillet 2008, 16:18:42
Merci ca marche


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: K@cem le 27 Juillet 2008, 17:25:07
Si tu n'écris qu'avec du Français dans ton site utilise l'encodage que t'as donné nitro007, mais si tu veux utiliser d'autres lettres (chinois, arabe ...) il faudra utiliser l'utf-8 mais aussi encoder ton fichier avec l'utf-8 ;)


Titre: Re: Affichage des lettres accentuées dans une page .php
Posté par: jpdollo le 27 Juillet 2008, 17:27:59
J'ai mis son code , les lettres accentuées de l'include remontent bien mais pas dans la page principale

le à devient A avec un signe dessus et é devient A@

Peux tu m'aider

Merci