Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL

Programmation => PHP/MySQL - (x)HTML - ... => Discussion démarrée; par: voltige.modélime le 08 Janvier 2010, 11:33:03



Titre: Probléme avec mes pages
Posté par: voltige.modélime le 08 Janvier 2010, 11:33:03
Voici mon site : modelclubdusanterre.com
Mon probléme : quand je clique sur une des pages de la rubrique info club (il n'y a que celle-ci qui sont en ligne) je n'ai que le header qui s'affiche (le css fait bien son travail   ::)  )
voici le code de mes pages il est le même pour toute les page j'ai fait un copier coller

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Bienvenue sur le site du Model Club du Santerre</title>
<link rel="stylesheet" type="text/css" href="http://modelclubdusanterre.webou.net/style.css"    />

</head>
<body>
<!--///////////////////////////////////  GLOBAL  ////////////////////////// -->

<div id="global">
<!--///////////////////////////////////  HEADER  ////////////////////////// -->
<div id="header"></div>

<!--///////////////////////////////////  MENU A GAUCHE  ////////////////////////// -->
<div id="menu">
                <?php include("http://modelclubdusanterre.webou.net/menu.html"?>
</div>
<!--///////////////////////////////////  CORPS  ////////////////////////// -->
<div id="corps">
<?php include("nwes.html"?>
</div>
<div id="footer">
<!--///////////////////////////////////  FOOTER  ////////////////////////// -->
<?php include("http://modelclubdusanterre.webou.net/footer.html")?>
     </div>
</div>
</body>
</html>
J'ai revérifier plusieur fois mes pages mais je n'ai rien trouver pouvez vous m'aider ???


Titre: Re: Probléme avec mes pages
Posté par: lepetitmarocain le 08 Janvier 2010, 11:39:32
Bonjour,

Vérifie ton PHP, surement une faute de code. (je n'y saurait t'y répondre j'aime pas le PHP)

++


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 08 Janvier 2010, 11:47:29
le php est bon  :'( je l'ai revérifier 15 fois au moins)


Titre: Re: Probléme avec mes pages
Posté par: MIkE le 08 Janvier 2010, 12:18:50
Bonjour,

 <?php include("nwes.html") ?> ?

Et aussi, on inclue pas seulement les php ?


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 08 Janvier 2010, 12:29:35
non avec la fonction include tu peut mettre des pages html la preuve pour mes menu sur ma page d'acceuil  c'est un include donc ca marche


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 08 Janvier 2010, 15:42:35
Personne n'a de solution pour moi ??????


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 08 Janvier 2010, 16:20:37
Gros PROBLEME
j'ai mis une copie de ma page index dans le même dossier que les pages qui ne fonctionne pas
resultat : elle ne marche pas il n'y a que le header qui s'affiche alors que la même page fonctionne en page d'acceuil
Je crois que cela ne relève plus de mon niveau mais plutôt des personne qui gère Webou pouvez vous m'aider svp
http://modelclubdusanterre.webou.net (http://modelclubdusanterre.webou.net) la page qui marche
http://modelclubdusanterre.webou.net/infoclub/index.html (http://modelclubdusanterre.webou.net/infoclub/index.html) la page qui ne marche pas
ces deux pages sont exactement les même


Titre: Re: Probléme avec mes pages
Posté par: lepetitmarocain le 08 Janvier 2010, 17:48:13
Bonsoir,

Je crois que c'est à cause de sa

Citation
/infoclub/index.html

index.html se trouve dans un dossier et ce n'est pas bon du tout.

++


Titre: Re: Probléme avec mes pages
Posté par: le hollandais volant le 09 Janvier 2010, 00:41:39
Salut à tous !

Perso, je serais de l'avis de Mike : je laisserais tomber le "include" pour prendre "require" ou "require_once" :

Code:
<? require_once('fichier'); ?>


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 09 Janvier 2010, 14:12:58
je vais tester


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 09 Janvier 2010, 16:37:59
marche pas ca change rien


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 09 Janvier 2010, 18:57:19
j'ai trouver le problème :
dans l'include il ne faut pas mettre de liens http://...
Voila
Merci quand même


Titre: Re: Probléme avec mes pages
Posté par: le hollandais volant le 09 Janvier 2010, 22:24:24
faut mettre le chemin relatif donc ?

du genre "../../fichier.html"
(cela remonte de 2 dossiers parents).


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 10 Janvier 2010, 10:13:31
Non pas un lien relatif un lien absolu
Pour ce qui ne veulent pas chercher le chemin absolu créez un fichier chemin.php dans lequel vous intégrez le code suivant :
Code:
<?php echo realpath('chemin.php'); ?>
vous mettez ce fichier dans le dossier dont vous voulez connaitre le lien absolu vous allez ensuite sur cette page et vous copiez collez ce que le navigateur vous affiche
C'est le lien absolu


Titre: Re: Probléme avec mes pages
Posté par: Bouyachaka le 10 Janvier 2010, 13:26:04
L'erreur ne venait pas de là include marche aussi avec les liens relatifs, la preuve je ne l'utilise presque qu'avec des chemins relatifs et je n'ai aucun problème avec, t'es sur que t'avais pas oublié un dossier entre deux ou une connerie du genre?

EDIT : je viens de taper http://.../nwes.html dans ma barre d'adresse et pof une belle erreur 404, le fichier est dans le dossier infoclub donc ton include aurait du être <?php include('infoclub/nwes.html') ?>, si ça marchait pas en lien relatif c'est juste qu'il était mal écrit.  ::)


Titre: Re: Probléme avec mes pages
Posté par: voltige.modélime le 10 Janvier 2010, 15:33:32
Cela ne venait pas de ce lien puisque sur toutes mes pages j'avais le méme probléme
Dans le doute j'évite d'utiliser les lien relatif

Pour ceux que ca intéresse j'ai fait un tuto http://www.webou.net/communaute/index.php/topic,3536.0.html (http://www.webou.net/communaute/index.php/topic,3536.0.html)