Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL

Programmation => PHP/MySQL - (x)HTML - ... => Discussion démarrée; par: toto62860 le 22 Mars 2010, 12:58:30



Titre: problème avec la fonction mail
Posté par: toto62860 le 22 Mars 2010, 12:58:30
bonjour ,
alors voila un problème avec cette fonction que je ne comprend pas du tout.
Des fois cette fonction ne "fonctionne" pas :s , suivant le mail qui est indiquer dans celle ci cela ne marche pas forcement :s
sur mon site j'envoi un mail à l'inscription pour vérifier la validité du mail , mais il arrive que le mail envoyer n'est jamais reçu par le destinataire.
peut être avez vous une solution ;) merci bien


Titre: Re: problème avec la fonction mail
Posté par: bricodx le 03 Avril 2010, 20:18:24
Salut

Es tu vraiment certain que les destinataires ne l'ont pas reçu ???? Car souvent, les courriers sont bloqués par un anti-spam, ou mis directement dans la boite à spam (pourriel).
Généralement, les destinataires ne surveillent cette boite et loupent certains messages.

Donc avant de chercher trop compliqué, perso je commencerai par là  ;)

A+ Fred


Titre: Re: problème avec la fonction mail
Posté par: toto62860 le 11 Avril 2010, 17:17:05
ah nan mais c'est bon , il les as recu mais bien plus tard ,c'est bizard :s


Titre: Re: problème avec la fonction mail
Posté par: bricodx le 16 Avril 2010, 19:02:36
Oui ça arrive, des fois on pourrait croire que le courrier est perdu tellement il met de temps à arriver (quand il arrive). Mais ça, c'est les mystères de l'internet  :D

A+ Fred



Titre: Re: problème avec la fonction mail
Posté par: clem182 le 16 Avril 2010, 22:44:17
Je sais pas si il y a un rapport, mais j'ai entendue parlé comme quoi les messages peuvent différer selon les boite de réception.

J'espère que ça peut aidé.


Titre: Re: problème avec la fonction mail
Posté par: bricodx le 19 Avril 2010, 01:41:27
Oui tout a fait.

certaines configurations de serveurs peuvent empêcher le transfert de mails avec certains noms de domaine. j'ai eu le problème avec une nom de domaine que j'avais pour un site, je ne recevais pas les mails envoyés à partir de divers sites.

Mais là, j'ai pas de solutions. Peut être qu'un professionnel des serveurs de mails pourrait nous en dire plus.

A+ Fred


Titre: Re: problème avec la fonction mail
Posté par: MrsB le 19 Avril 2010, 09:24:21
Bonjour,

je viens d'aller voir ton site.
Une autre suggestion a priori, mais, heu... c'est délicat.

Les personnes qui se sont inscrites mais n'ont rien reçu n'auraient-elles pas choisi un login un peu trop olé-olé pour être toléré par leur antispam?
Fais-tu apparaître le login en question dans le titre du mail?
Ou même le nom du site?


Titre: Re: problème avec la fonction mail
Posté par: toto62860 le 26 Avril 2010, 18:12:10
Pas dans le titre mais dans le contenu...
mais je ne sais pas si cela a tellement d'importance dans le contenu.


Titre: Re: problème avec la fonction mail
Posté par: MrsB le 27 Avril 2010, 02:06:25
Je vais te donner la réponse qui énerve: ça dépend... ;D

Ca dépend de l'antivirus, du réglage, de la boîte qui peut aussi avoir sa sensibilité... Essaie de créer des utilisateurs fictifs qui envoient les mails dans des boîtes t'appartenant... et essaie de déduire si c'est ça qui fait planter...
Et efface tes mails après sinon bonjour les scènes de ménage  ;D


Titre: Re: problème avec la fonction mail
Posté par: toto62860 le 01 Mai 2010, 18:05:16
je ne suis pas encore près d'avoir des scène de ménage , je n'ai que 18 ans après tout alors de ce coté tout va bien :)
et je vais effectuer vos teste je vous tiendrez au courant ;)
merci a vous