Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL Webou Webou Pro
Recherche avancée  
*
Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre courriel d'activation?
18 Octobre 2018, 23:23:49


Connexion avec identifiant, mot de passe et durée de la session


Pages: 1 [2]   Bas de page
  Imprimer  
Auteur Fil de discussion: après transfert: 500 internal server error  (Lu 6654 fois)
0 Membres et 1 Invité sur ce fil de discussion.
K@cem
Never trust user input
Big boss
*****
Hors ligne Hors ligne

Messages: 2 724



Voir le profil WWW
« Répondre #15 le: 12 Juin 2007, 23:49:34 »

L'interclassement pose des problèmes de formatage de données, mais ça n'as aucun rapport avec l'installation d'un script php ...
(ça peut poser des problèmes lors de l'insertion mais si c'était le cas ce forum ne marchera pas aussi  Grimaçant )
Donc faut pas chercher de ce coté là !

Tes posts sont mal organisé, donc si tu récapitule en 2 lignes ton problème je pense que ça serait plus visible (en tous cas pour moi ...)  Clin d'oeil

Merci
Journalisée

Le support ne se fait pas par MP, merci de le respecter !
Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL
« Répondre #15 le: 12 Juin 2007, 23:49:34 »

 Journalisée
Nguékokh
Nouveau
*
Hors ligne Hors ligne

Messages: 13


Voir le profil
« Répondre #16 le: 14 Juin 2007, 15:20:11 »

Bonjour,
Mike, je viens de t'envoyer les back up.
Donc récap et résumé:
2 pistes:
- soit les fichiers à la racine de mon compte, au niveau au-dessus de /public_html comportent des erreurs: pas impossible que en uploadant mon site depuis le local ( ce que j'ai dû faire, vu que le back up n'était pas fiable), j'ai écrasé des fichiers de la nouvelle instal
- soit le paramétrage bdd sur le serveur.
Pour répondre à Mike:
- non, je restaure ma base uniquement via spip et donc evidemment après la ré instal de Spip (en supp le "inc_connect")
- La restau n'est pas en cause, puisque mon dernier essai était avec une base créé par l'instal de spip et sans restaur:
Ce qui s'est passé (je remet le post):
- J'ai recréé une base et un user
- Base vide,je choisis l'interclassement utf8_general_ci
- Je relance l'instal de Spip> il recrée les tables vides
- Mais sur My admin, l'interclassement affiché= latin1_swedish_ci !
- Le site s'affiche avec la nouvelle instal.
- Je fait un f5 sur le site qq minutes après et j'ai l'erreur 500.
- Par contre j'ai toujours accès à l'admin de spip
- J'ai créé un article bidon. dans l'admin Spip, le texte n'apparait pas en prévisualisation, mais qd je fais modifier l'article, le texte est bien là.
Journalisée
Nguékokh
Nouveau
*
Hors ligne Hors ligne

Messages: 13


Voir le profil
« Répondre #17 le: 14 Juin 2007, 15:24:39 »

Bonjour,
Mike, je viens de t'envoyer les back up.
Ah je viens de voir que ça a bougé.
A suivre...
Je laisse mes explics ci-dessous qd même.

Donc récap et résumé:
2 pistes:
- soit les fichiers à la racine de mon compte, au niveau au-dessus de /public_html comportent des erreurs: pas impossible que en uploadant mon site depuis le local ( ce que j'ai dû faire, vu que le back up n'était pas fiable), j'ai écrasé des fichiers de la nouvelle instal
- soit le paramétrage bdd sur le serveur.
Pour répondre à Mike:
- non, je restaure ma base uniquement via spip et donc evidemment après la ré instal de Spip (en supp le "inc_connect")
- La restau n'est pas en cause, puisque mon dernier essai était avec une base créé par l'instal de spip et sans restaur:
Ce qui s'est passé (je remet le post):
- J'ai recréé une base et un user
- Base vide,je choisis l'interclassement utf8_general_ci
- Je relance l'instal de Spip> il recrée les tables vides
- Mais sur My admin, l'interclassement affiché= latin1_swedish_ci !
- Le site s'affiche avec la nouvelle instal.
- Je fait un f5 sur le site qq minutes après et j'ai l'erreur 500.
- Par contre j'ai toujours accès à l'admin de spip
- J'ai créé un article bidon. dans l'admin Spip, le texte n'apparait pas en prévisualisation, mais qd je fais modifier l'article, le texte est bien là.
Journalisée
MIkE
Big boss
*****
Hors ligne Hors ligne

Messages: 6 196



Voir le profil WWW
« Répondre #18 le: 14 Juin 2007, 15:33:25 »

Bien reçu, j'ai tout refait et installé correctement, je regarde la cause de 500...
Journalisée

Le support et les demandes se font sur le forum. Aucune réponse n'est apportée aux demandes par message privé.
Soutenez Webou en souscrivant à une offre
Nguékokh
Nouveau
*
Hors ligne Hors ligne

Messages: 13


Voir le profil
« Répondre #19 le: 15 Juin 2007, 21:15:12 »

Bonjour,
Re réinstal, restauretc...Je veux comprendre ce bins quoi... Sourire
J'ai installé le site sur http://photographenature.free.fr pour comparer et trouver le bug sur webou.
J'ai aussi fait cet instal sur free avec un autre interclassement  pour voir:
Interclassement pour la connection MySQL:utf8_general_ci 
et pour les tables :latin1_general_ci
Tout marche.
Sur Webou: j'ai supprimé le texte de l'article de l'accueil (en l'enlevant dans l'admin, ce qui correspond au champ #TEXTE dans spip) et la page s'affiche.
Autre test: Si je supprime le #TEXTE dans mes boucles, tout marche.
On peut tester sur http://nguekokh.webou.net/spip.php?page=plan :
seuls les articles ou les rubriques sans texte rentré dans spip s'affichent sans erreur 500.

Donc voila, si ça vous inspire...
Hypothèse: le serveur se mélange les pinceaux avec un interclassement avec lequel il ne peut afficher le texte.
Voir dans My Admin :  Table: spip_rubriques>texte  longblob
Re-question: Pourquoi utf8_unicode_ci (posant problème de casse) proposé par défaut sur le nouveau serveur de Webou au lieu de utf8_general_ci comme avnt et comme sur free par exemple?
cf Jeux de caractères et interclassement sur My Admin.

Mike est ce que tu crois que tu peut arranger ou je dois faire avec (car  ça peut peut-être gêner les bdd d'autres membres)?
J'ai besoin de savoir assez vite car ils vont me renvoyer d'autres textes bientôt du sénégal.

Merci à vous
A+
Journalisée
Forums Webou.net - Hébergement gratuit et sans publicités avec PHP/MySQL
« Répondre #19 le: 15 Juin 2007, 21:15:12 »

 Journalisée
MIkE
Big boss
*****
Hors ligne Hors ligne

Messages: 6 196



Voir le profil WWW
« Répondre #20 le: 15 Juin 2007, 22:52:02 »

Bon honnêtement, j'ai cherché dans tout ce que je pouvais ici, j'ai fait appel à l'extérieur, et on n'a pas trouvé le problème.

Alors oui apparemment ça pourrait être un problème d'interclassement. Pour l'instant je n'ai pas eu le temps de voir pourquoi c'était celui-là par défaut, et pas l'autre. Je vais faire quelques recherches, voir si ça pose un problème, et si c'est le cas, je tenterai de modifier les paramètres pour que ce ne soit plus le cas.

Si pour l'instant tu peux faire avec les paramètres actuels, fais comme ça, parce que ça va prendre au moins quelques jours ou semaines, vu qu'on est assez occupés en ce moment sur d'autres aspects comme la ré-ouverture des inscriptions.
Journalisée

Le support et les demandes se font sur le forum. Aucune réponse n'est apportée aux demandes par message privé.
Soutenez Webou en souscrivant à une offre
Nguékokh
Nouveau
*
Hors ligne Hors ligne

Messages: 13


Voir le profil
« Répondre #21 le: 16 Juin 2007, 19:43:07 »

Ok merci pour ta réponse.
Pour l'instant ils n'ont pas l'air dans l'hyper urgence au Sénégal mais si ça devient le cas (pour convaincre des partenaires), faudra que j'ai un truc montrable.
En ce cas, si ça te va ( et je te dirai avant), est ce que je pourrai faire une redirection vers le site Free, temporaire bien sûre (juste un refresh sur l'accueil), le temps qu'on trouve un compromis pour l'interclassement qui ne pose pas de problème pour vos autres sites.
(Le souci c'est que les sites Free en comptes secondaires bloquent le FTP de l'étranger, pas pratique)
De mon côté, je vais chercher aussi de la doc et des infos My Sql.
Bah au moins j'ai appris des trucs.
 Sourire
A+
Journalisée
K@cem
Never trust user input
Big boss
*****
Hors ligne Hors ligne

Messages: 2 724



Voir le profil WWW
« Répondre #22 le: 16 Juin 2007, 19:47:04 »

Lis mon MP Sourire
Journalisée

Le support ne se fait pas par MP, merci de le respecter !
Pages: 1 [2]   Haut de page
  Imprimer  
 
Aller à:  

Propulsé par MySQL Propulsé par PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Dilber MC Theme by HarzeM
Page générée en 0.036 secondes avec 22 requêtes.